Frequently Asked Questions / Anveo Mobile App / User replication fails with Anveo Server error “Unauthorized”

User replication fails with Anveo Server error “Unauthorized”

Symptom

Anveo User Replication in Anveo Set-up fails. Anveo Server log shows error message “Unauthorized”.

Cause

  • Username, domain name or password are incorrect.
  • User is not set-up as a Dynamics NAV user or does not have Dynamics NAV rights.
  • Anveo Server is not to NTLM = true.
  • Web service is not set to NTLM = true.
  • NAV 2009 only: Delegation is not set-up properly.

Solution

  • Open your Web Service using http://yourservername/DynamicsNAV/WS/Services using domain name, username and password with your Internet Explorer and test your credentials.
    Domain\User
    Note: DynamicsNAV is the instance name of your Dynamics web service. It may be different like DynamicsNAV70 or DynamicsNAV80.
  • Set Anveo Server to NTLM true
  • Set Web Service to NTLM true and restart Web Service.
    Note for NAV 2009: Stop Dynamics NAV Server and Web Service first, then start services again. Do not restart both services directly.
  • NAV 2009 only: Try to use Web Services without delegation first. Set-up web service on your SQL server.